GitHub Advisoryadvisory · npm

GHSA-8423-w5wx-h2r6 Pannellum has a XSS vulnerability in hot spot attributes

MEDIUM Published 2026-02-19 Modified 2026-02-23 Official page ↗
Aliases
CVE-2026-27210
Ecosystem
npm
Packages
pannellum
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2026-02-19

Affected packages

• npm pannellum: >= 2.5.0, < 2.5.7 → fixed in 2.5.7

Description

Impact The hot spot `attributes` configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the `escapeHTML` parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file&mdash;without additional user interaction&mdash;is sufficient to trigger the vulnerability and execute arbitrary JavaScript code, which can, for example, replace the contents of the page with arbitrary content and make it appear to be hosted by the website hosting the standalone viewer HTML file. Patches This has been fixed both in v2.5.7 and in the current development branch. Workarounds Setting the `Content-Security-Policy` header to `script-src-attr 'none'` will block execution of inline event handlers, mitigating this vulnerability. Don't host `pannellum.htm` on a domain that shares cookies with user authentication to mitigate XSS risk. Acknowledgments Reported both by luminary (@lumin9ry), Visvge (@Sicclord1 / @Visvge), and sutol (@0x5a6163 / @SUT0L) and by another researcher who wishes not to be named at this time.

Related

Alias · CVE (1)

  • CVE-2026-27210 Pannellum is a lightweight, free, and open source panorama viewer for the web. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References