GitHub Advisoryadvisory · npm
GHSA-8478-53pv-jxvm Joplin Vulnerable to Code Injection
CRITICAL
Official page ↗
- Aliases
- CVE-2022-23340
- Ecosystem
- npm
- Packages
- joplin
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2024-04-23
Affected packages
• npm joplin: < 2.7.1 → fixed in 2.7.1
Description
Joplin prior to version 2.7.1 allows remote attackers to execute system commands through malicious code in user search results.
Related
Alias · CVE (1)
- CVE-2022-23340 Joplin 2.6.10 allows remote attackers to execute system commands through malicious code in user search results. vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness