GitHub Advisoryadvisory · PyPI

GHSA-85q9-7467-r53q XSS Vulnerability in Markdown Editor

HIGH Published 2022-06-17 Modified 2026-04-24 Official page ↗
Ecosystem
PyPI
Packages
inventree
Severity
High
Weaknesses
CWE-79
Reviewed
2022-06-17

Affected packages

• PyPI inventree: < 0.7.3 → fixed in 0.7.3

Description

Impact InvenTree uses EasyMDE for displaying markdown text in various places (e.g. for the various "notes" fields associated with various models). By default, EasyMDE does not sanitize input data, and it is possible for malicious code to be injected into the markdown editor, and executed in the users browser. *Note: This malicious data must be first uploaded to the database by an authorized user, so the risk here is limited to trusted users* Solution The solution here is two-fold: • Enable data sanitization for the EasyMDE renderer - #3205 • Enforce cleaning of all data uploaded to the database via the API - #3204 *(This will be ready for the 0.8.0 release)* Patches • The issue is addressed in the 0.8.0 release • This fix was back-ported to the 0.7.x branch, applied to the 0.7.3 release Workarounds There is no workaround for this issue without upgrading InvenTree to the specified version. References • https://huntr.dev/bounties/ab296cf5-7a3e-4f49-8f63-5b35fc707f03/ For more information If you have any questions or comments about this advisory: • Open an issue in github • Email us at [email protected]

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References