GitHub Advisoryadvisory · Maven
GHSA-864w-r5qj-h6fj Apache Struts forced double OGNL evaluation
HIGH
Official page ↗
- Aliases
- CVE-2016-4461
- Ecosystem
- Maven
- Packages
- org.apache.struts:struts2-core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20, CWE-74
- Reviewed
- 2025-04-23
Affected packages
• Maven org.apache.struts:struts2-core: >= 2.0.0, < 2.3.29 → fixed in 2.3.29
Description
Apache Struts 2.x before 2.3.29 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced double OGNL evaluation. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-0785.
Related
Alias · CVE (1)
- CVE-2016-4461 Apache Struts 2.x before 2.3.29 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced… vulnerability