GitHub Advisoryadvisory · npm

GHSA-866g-f22w-33x8 @ai-sdk/provider-utils has an Uncontrolled Resource Consumption issue

LOW Published 2026-05-18 Modified 2026-09-08 Official page ↗
Aliases
CVE-2026-8769
Ecosystem
npm
Packages
@ai-sdk/provider-utils
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-400
Reviewed
2026-05-29

Affected packages

• npm @ai-sdk/provider-utils: < 3.0.28 → fixed in 3.0.28 • npm @ai-sdk/provider-utils: >= 4.0.0-beta.10, < 4.0.33 → fixed in 4.0.33 • npm @ai-sdk/provider-utils: >= 5.0.0-beta.0, < 5.0.1 → fixed in 5.0.1

Description

Versions of `@ai-sdk/provider-utils` before 3.0.28, from 4.0.0 before 4.0.33, and from 5.0.0 before 5.0.1 are vulnerable to uncontrolled resource consumption. The `createJsonResponseHandler`, `createJsonErrorResponseHandler`, and `createStatusCodeErrorResponseHandler` functions in `packages/provider-utils/src/response-handler.ts` read response bodies without a shared size limit, allowing a remote attacker with low privileges to cause excessive memory consumption. The exploit has been publicly disclosed and may be utilized.

Related

Alias · CVE (1)

  • CVE-2026-8769 A vulnerability was determined in vercel ai up to 3.0.97. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References