GitHub Advisoryadvisory · Go

GHSA-8697-479h-5mfp Weaviate denial of service vulnerability

HIGH Published 2023-08-22 Modified 2023-08-24 Official page ↗
Aliases
CVE-2023-38976
Ecosystem
Go
Packages
github.com/weaviate/weaviate
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-704
Reviewed
2023-08-22

Affected packages

• Go github.com/weaviate/weaviate: >= 1.20.0, < 1.20.6 → fixed in 1.20.6 • Go github.com/weaviate/weaviate: >= 1.19.0, < 1.19.13 → fixed in 1.19.13 • Go github.com/weaviate/weaviate: < 1.18.6 → fixed in 1.18.6

Description

Impact This vulnerability is a type conversion issue that affects users of Weaviate Server versions 1.20.0 and earlier. Who is impacted: Users of Weaviate Server versions 1.20.0 and earlier are impacted by this vulnerability. Patches A patch has been developed for this vulnerability. Patch releases 1.20.6, 1.19.13, and 1.18.6 are fixing this vulnerability in each respective minor version release. Users are strongly recommended to upgrade to one of these patched versions to address the vulnerability. Keeping software up-to-date is crucial to avoid security vulnerabilities. Workarounds There are no known workarounds to fix or remediate this vulnerability without upgrading. Users must upgrade to a patched version to mitigate the risk. References • https://github.com/weaviate/weaviate/releases/tag/v1.18.6 • https://github.com/weaviate/weaviate/releases/tag/v1.19.13 • https://github.com/weaviate/weaviate/releases/tag/v1.20.6

Related

Alias · CVE (1)

  • CVE-2023-38976 An issue in weaviate v.1.20.0 allows a remote attacker to cause a denial of service via the handleUnbatchedGraphQLRequest function. vulnerability

Weakness · CWE (1)

  • CWE-704 Incorrect Type Conversion or Cast weakness

References