GitHub Advisoryadvisory · PyPI

GHSA-86vp-x3pr-79rx Apache Airflow cross-site scripting due to incomplete fix for CVE-2020-13944

MEDIUM Published 2021-04-20 Modified 2024-09-11 Official page ↗
Aliases
CVE-2020-17515
Ecosystem
PyPI
Packages
apache-airflow
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2021-04-08

Affected packages

• PyPI apache-airflow: < 1.10.15rc1 → fixed in 1.10.15rc1 • PyPI apache-airflow: >= 2.0.0b1, < 2.0.2rc1 → fixed in 2.0.2rc1

Description

The `origin` parameter passed to some of the endpoints like `/trigger` was vulnerable to XSS exploit. This issue affects Apache Airflow versions prior to 1.10.15. This is same as CVE-2020-13944 but the implemented fix in Airflow 1.10.13 did not fix the issue completely.

Related

Alias · CVE (1)

  • CVE-2020-17515 The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References