GitHub Advisoryadvisory · Packagist

GHSA-873m-72g6-853g Magento Open Source Cross-Site Scripting (XSS) vulnerability

MEDIUM Published 2024-10-10 Modified 2024-10-11 Official page ↗
Aliases
CVE-2024-45116
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2024-10-11

Affected packages

• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p3 → fixed in 2.4.7-p3 • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p8 → fixed in 2.4.6-p8 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p10 → fixed in 2.4.5-p10 • Packagist magento/community-edition: < 2.4.4-p11 → fixed in 2.4.4-p11 • Packagist magento/community-edition: 2.4.7 (no fix yet) • Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet)

Description

Magento Open Source versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by a Cross-Site Scripting (XSS) vulnerability that could be exploited to execute arbitrary code. If an admin attacker can trick a user into clicking a specially crafted link or submitting a form, malicious scripts may be executed within the context of the victim's browser and have high impact on confidentiality and integrity. Exploitation of this issue requires user interaction.

Related

Alias · CVE (1)

  • CVE-2024-45116 Adobe Commerce versions 2.4.7-p2, 2.4.6-p7, 2.4.5-p9, 2.4.4-p10 and earlier are affected by a Cross-Site Scripting (XSS) vulnerability that… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References