GitHub Advisoryadvisory · PyPI

GHSA-873q-wpqr-xfgw Bottle does not properly limit content-types

HIGH Published 2022-05-17 Modified 2024-09-13 Official page ↗
Aliases
CVE-2014-3137
Ecosystem
PyPI
Packages
bottle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2023-08-16

Affected packages

• PyPI bottle: >= 0.10.0, < 0.10.12 → fixed in 0.10.12 • PyPI bottle: >= 0.11.0, < 0.11.7 → fixed in 0.11.7 • PyPI bottle: >= 0.12.0, < 0.12.6 → fixed in 0.12.6

Description

Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote attackers to bypass intended access restrictions via an accepted Content-Type followed by a `;` (semi-colon) and a Content-Type that would not be accepted, as demonstrated in YouCompleteMe to execute arbitrary code.

Related

Alias · CVE (1)

  • CVE-2014-3137 Bottle 0.10.x before 0.10.12, 0.11.x before 0.11.7, and 0.12.x before 0.12.6 does not properly limit content types, which allows remote… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References