GitHub Advisoryadvisory · Maven
GHSA-876p-4wgc-75rx Apache Struts RCE Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2016-0785
- Ecosystem
- Maven
- Packages
- org.apache.struts:struts2-core
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-07-28
Affected packages
• Maven org.apache.struts:struts2-core: >= 2.0.0, < 2.3.20.3 → fixed in 2.3.20.3
• Maven org.apache.struts:struts2-core: >= 2.3.24, < 2.3.24.3 → fixed in 2.3.24.3
Description
Apache Struts 2.x before 2.3.20.3, 2.3.24.3, and 2.3.28 allows remote attackers to execute arbitrary code via a `%{}` sequence in a tag attribute, aka forced double OGNL evaluation.
Related
Alias · CVE (1)
- CVE-2016-0785 Apache Struts 2.x before 2.3.28 allows remote attackers to execute arbitrary code via a "%{}" sequence in a tag attribute, aka forced… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-0785 advisory
- https://github.com/apache/struts/commit/15857a69e7baf3675804495a5954cd0756ac8364 web
- https://github.com/apache/struts package
- https://web.archive.org/web/20210123095715/http://www.securityfocus.com/bid/85066 web
- https://web.archive.org/web/20220118185853/http://www.securitytracker.com/id/1035271 web
- http://struts.apache.org/docs/s2-029.html web