GitHub Advisoryadvisory · PyPI

GHSA-8863-4qmg-fr45 Apache Airflow Fab Provider Insufficient Session Expiration vulnerability

LOW Published 2025-01-08 Modified 2025-01-08 Official page ↗
Aliases
CVE-2024-45033
Ecosystem
PyPI
Packages
apache-airflow-providers-fab
Severity
Low
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
Weaknesses
CWE-613
Reviewed
2025-01-08

Affected packages

• PyPI apache-airflow-providers-fab: < 1.5.2 → fixed in 1.5.2

Description

Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. This issue affects Apache Airflow Fab Provider: before 1.5.2. When user password has been changed with admin CLI, the sessions for that user have not been cleared, leading to insufficient session expiration, thus logged users could continue to be logged in even after the password was changed. This only happened when the password was changed with CLI. The problem does not happen in case change was done with webserver thus this is different from CVE-2023-40273 which was addressed in Apache-Airflow 2.7.0 Users are recommended to upgrade to version 1.5.2, which fixes the issue.

Related

Weakness · not in database (1)

Alias · CVE (1)

  • CVE-2024-45033 Insufficient Session Expiration vulnerability in Apache Airflow Fab Provider. vulnerability

References