GitHub Advisoryadvisory · npm
GHSA-8864-rhmw-5m6f Status Board vulnerable to Cross-Site Scripting before v1.1.82
MEDIUM
Official page ↗
- Aliases
- CVE-2019-15479
- Ecosystem
- npm
- Packages
- status-board
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2019-09-19
Affected packages
• npm status-board: < 1.1.82 → fixed in 1.1.82
Description
Versions of `status-board` prior to 1.1.82 are vulnerable to Cross-Site Scripting. The `renderDashboard()` function concatenates the `safeDashboard` variable to the printed error message with insufficient sanitization. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser.
Recommendation
Upgrade to version 1.1.82 to receive a patch.
Related
Alias · CVE (1)
- CVE-2019-15479 Status Board 1.1.81 has reflected XSS via dashboard.ts. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-15479 advisory
- https://github.com/jameswlane/status-board/pull/948 web
- https://github.com/status-board/status-board/commit/19106617865406aa6f8edec036dcb1db427d5f71 web
- https://github.com/jameswlane/status-board package
- https://snyk.io/vuln/SNYK-JS-STATUSBOARD-460295 web