GitHub Advisoryadvisory · Maven
GHSA-8886-8v27-85j8 Stored XSS vulnerability in Jenkins Authorize Project Plugin
HIGH
Official page ↗
- Aliases
- CVE-2024-52552
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:authorize-project
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2024-11-14
Affected packages
• Maven org.jenkins-ci.plugins:authorize-project: < 1.8.0 → fixed in 1.8.0
Description
Jenkins Authorize Project Plugin 1.7.2 and earlier evaluates a string containing the job name with JavaScript on the Authorization view, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Authorize Project Plugin 1.8.0 no longer evaluates a string containing the job name with JavaScript on the Authorization view.
Related
Alias · CVE (1)
- CVE-2024-52552 Jenkins Authorize Project Plugin 1.7.2 and earlier evaluates a string containing the job name with JavaScript on the Authorization view,… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness