GitHub Advisoryadvisory · RubyGems

GHSA-88cv-mj24-8w3q arr-pm vulnerable to arbitrary shell execution when extracting or listing files contained in a malicious rpm.

HIGH Published 2022-09-21 Modified 2022-09-21 Official page ↗
Aliases
CVE-2022-39224
Ecosystem
RubyGems
Packages
arr-pm
Severity
High
CVSS vector
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-78
Reviewed
2022-09-21

Affected packages

• RubyGems arr-pm: < 0.0.12 → fixed in 0.0.12

Description

Impact Arbitrary shell execution is possible when using RPM::File#files and RPM::File#extract if the RPM contains a malicious "payload compressor" field. This vulnerability impacts the `extract` and `files` methods of the `RPM::File` class in the affected versions of this library. Patches Version 0.0.12 is available with a fix for these issues. Workarounds When using an affected version of this library (arr-pm), ensure any RPMs being processed contain valid/known payload compressor values. Such values include: gzip, bzip2, xz, zstd, and lzma. You can check the payload compressor field in an rpm by using the rpm command line tool. For example: ``` % rpm -qp example-1.0-1.x86_64.rpm --qf "%{PAYLOADCOMPRESSOR}\n" gzip ``` Impact on known dependent projects This library is used by fpm. The vulnerability may impact fpm only when using the flag `-s rpm` or `--input-type rpm` to convert a malicious rpm to another format. It does not impact creating rpms. References • https://github.com/jordansissel/ruby-arr-pm/pull/14 • https://github.com/jordansissel/ruby-arr-pm/pull/15 Credit Thanks to @joernchen for reporting this problem and contributing to the resolution :) For more information If you have any questions or comments about this advisory: • Open an issue in the arr-pm issue tracker

Related

Alias · CVE (1)

  • CVE-2022-39224 Arr-pm is an RPM reader/writer library written in Ruby. vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References