GitHub Advisoryadvisory · npm
GHSA-8948-ffc6-jg52 Insecure Default Configuration in redbird
MEDIUM
Official page ↗
- Ecosystem
- npm
- Packages
- redbird
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2019-06-06
Affected packages
• npm redbird: <= 0.9.0 (no fix yet)
Description
Versions of `redbird` prior to 0.9.1 have a vulnerable default configuration of allowing TLS 1.0 connections on `lib/proxy.js`. The package does not provide an option to disable TLS 1.0 which is deprecated and vulnerable.
Recommendation
Upgrade to version 0.9.1 or later.
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness