GitHub Advisoryadvisory · PyPI
GHSA-894g-6j7q-2hx6 Flask-Admin Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2018-16516
- Ecosystem
- PyPI
- Packages
- Flask-Admin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• PyPI Flask-Admin: < 1.5.3 → fixed in 1.5.3
Description
helpers.py in Flask-Admin 1.5.2 has Reflected XSS via a crafted URL.
Related
Alias · CVE (1)
- CVE-2018-16516 helpers.py in Flask-Admin 1.5.2 has Reflected XSS via a crafted URL. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-16516 advisory
- https://github.com/flask-admin/flask-admin/pull/1699 web
- https://github.com/flask-admin/flask-admin/commit/8af10e0b022464fdcb2da3d0ea5bbd2f11c0acd1 web
- https://github.com/advisories/GHSA-894g-6j7q-2hx6 advisory
- https://github.com/flask-admin/flask-admin package
- https://github.com/flask-admin/flask-admin/releases/tag/v1.5.3 web
- https://github.com/pypa/advisory-database/tree/main/vulns/flask-admin/PYSEC-2018-54.yaml web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UJIYCWIH3BRLI2QNC53CQXLKVP27X7EH web
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZU2VKULURVXEU4YFTLMBQGYMPSXQ4MBN web