GitHub Advisoryadvisory · Packagist
GHSA-89cp-fvcc-hxh7 Symfony Access Control Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2012-6432
- Ecosystem
- Packagist
- Packages
- symfony/symfony
- Severity
- Moderate
- Weaknesses
- CWE-284
- Reviewed
- 2023-08-15
Affected packages
• Packagist symfony/symfony: 2.2-dev (no fix yet)
• Packagist symfony/symfony: >= 2.0.0, < 2.0.20 → fixed in 2.0.20
• Packagist symfony/symfony: >= 2.1.0, < 2.1.5 → fixed in 2.1.5
Description
Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to access arbitrary services via vectors involving a URI beginning with a `/_internal` substring.
Related
Alias · CVE (1)
- CVE-2012-6432 Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-6432 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2012-6432.yaml web
- https://github.com/symfony/symfony package
- https://symfony.com/blog/security-release-symfony-2-0-20-and-2-1-5-released web
- http://symfony.com/blog/security-release-symfony-2-0-20-and-2-1-5-released web