GitHub Advisoryadvisory · Packagist

GHSA-8c28-5mp7-v24h TYPO3 CMS vulnerable to Denial of Service in Page Error Handling

MEDIUM Published 2022-12-13 Modified 2022-12-13 Official page ↗
Aliases
CVE-2022-23500
Ecosystem
Packagist
Packages
typo3/cms-core, typo3/cms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-405, CWE-674
Reviewed
2022-12-13

Affected packages

• Packagist typo3/cms-core: >= 9.0.0, < 9.5.38 → fixed in 9.5.38 • Packagist typo3/cms-core: >= 10.0.0, < 10.4.33 → fixed in 10.4.33 • Packagist typo3/cms-core: >= 11.0.0, < 11.5.20 → fixed in 11.5.20 • Packagist typo3/cms: >= 10.0.0, < 10.4.33 → fixed in 10.4.33 • Packagist typo3/cms: >= 11.0.0, < 11.5.20 → fixed in 11.5.20

Description

Problem Requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in TYPO3-CORE-SA-2021-005 (CVE-2021-21359). Solution Update to TYPO3 versions 9.5.38 ELTS, 10.4.33 or 11.5.20 that fix the problem described above. References • TYPO3-CORE-SA-2022-012

Related

Alias · CVE (1)

  • CVE-2022-23500 TYPO3 is an open source PHP based web content management system. vulnerability

Weakness · CWE (2)

  • CWE-405 Asymmetric Resource Consumption (Amplification) weakness
  • CWE-674 Uncontrolled Recursion weakness

References