GitHub Advisoryadvisory · RubyGems
GHSA-8c56-cpmw-89x7 Out-of-bounds read in nokogiri
HIGH
Official page ↗
- Aliases
- CVE-2017-9050
- Ecosystem
- RubyGems
- Packages
- nokogiri
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-125
- Reviewed
- 2020-06-16
Affected packages
• RubyGems nokogiri: < 1.8.1 → fixed in 1.8.1
Description
libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839. GitHub is notifying on nokogiri as uses libxml2.
Related
Alias · CVE (1)
- CVE-2017-9050 libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. vulnerability
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness