GitHub Advisoryadvisory · npm

GHSA-8c8c-4vfj-rrpc Reflected Cross-Site Scripting in redis-commander

LOW Published 2020-09-01 Modified 2022-03-04 Official page ↗
Ecosystem
npm
Packages
redis-commander
Severity
Low
Weaknesses
CWE-79
Reviewed
2020-08-31

Affected packages

• npm redis-commander: >= 0.0.0, < 0.5.0 → fixed in 0.5.0

Description

Affected versions of `redis-commander` contain a cross-site scripting vulnerability in the `highlighterId` paramter of the clipboard.swf component on hosts serving Redis Commander. Mitigating factors: Flash must be installed / enabled for this to work. The below proof of concept was verified to work using Firefox 57.0 on Windows 10 by manually installing the Flash NPAPI Windows plugin Proof of concept ``` http://instance/jstree/_docs/syntax/clipboard.swf?highlighterId=\%22))}%20catch(e)%20{alert(document.domain);}// ``` Recommendation No direct patch for this vulnerability is currently available. At this time, the best mitigation is to use an alternative, functionally equivalent package, or to use extreme caution when using redis-commander, ensuring that redis-commmander is the only web page you have open, and avoiding clicking on any links.

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References