GitHub Advisoryadvisory · Packagist

GHSA-8cw5-rv98-5c46 Arbitrary PHP code execution in Drupal

CRITICAL Published 2022-01-06 Modified 2022-01-06 Official page ↗
Aliases
CVE-2019-6339
Ecosystem
Packagist
Packages
drupal/drupal, drupal/core
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2022-01-06

Affected packages

• Packagist drupal/drupal: >= 7.0.0, < 7.62.0 → fixed in 7.62.0 • Packagist drupal/drupal: >= 8.0.0, < 8.5.9 → fixed in 8.5.9 • Packagist drupal/drupal: >= 8.6.0, < 8.6.6 → fixed in 8.6.6 • Packagist drupal/core: >= 7.0.0, < 7.62.0 → fixed in 7.62.0 • Packagist drupal/core: >= 8.0.0, < 8.5.9 → fixed in 8.5.9 • Packagist drupal/core: >= 8.6.0, < 8.6.6 → fixed in 8.6.6

Description

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6, and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.

Related

Alias · CVE (1)

  • CVE-2019-6339 In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References