GitHub Advisoryadvisory · npm
GHSA-8f64-q7jc-ccgp metascraper before v5.2.0 vulnerable to stored cross-site scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2018-3773
- Ecosystem
- npm
- Packages
- metascraper
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• npm metascraper: < 5.2.0 → fixed in 5.2.0
Description
Versions of `metascraper` prior to 5.2.0 are vulnerable to stored cross-site scripting (XSS).
Recommendation
Upgrade to version 5.2.0 or later.
Related
Alias · CVE (1)
- CVE-2018-3773 There is a stored Cross-Site Scripting vulnerability in Open Graph meta properties read by the `metascrape` npm module <= 3.9.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness