GitHub Advisoryadvisory · PyPI
GHSA-8fg4-j562-mjrc Improper Input Validation in Apache Airflow resulting in Remote Code Execution
HIGH
Official page ↗
- Aliases
- CVE-2017-15720
- Ecosystem
- PyPI
- Packages
- apache-airflow
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2020-06-16
Affected packages
• PyPI apache-airflow: < 1.9.0 → fixed in 1.9.0
Description
In Apache Airflow 1.8.2 and earlier, an authenticated user can execute code remotely on the Airflow webserver by creating a special object.
Related
Alias · CVE (1)
- CVE-2017-15720 In Apache Airflow 1.8.2 and earlier, an authenticated user can execute code remotely on the Airflow webserver by creating a special object. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-15720 advisory
- https://github.com/apache/airflow/commit/04cacdd0a7526927137b452f38c3e894a5d2ce4a web
- https://github.com/apache/airflow/commit/daa281c0364609d6812921123cf47e4118b40484 web
- https://github.com/advisories/GHSA-8fg4-j562-mjrc advisory
- https://github.com/apache/airflow package
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2019-147.yaml web
- https://lists.apache.org/thread.html/ade4d54ebf614f68dc81a08891755e60ea58ba88e0209233eeea5f57@%3Cdev.airflow.apache.org%3E web