GitHub Advisoryadvisory · PyPI
GHSA-8fg9-p83m-x5pq ReDoS issue in dparse
HIGH
Official page ↗
- Aliases
- CVE-2022-39280
- Ecosystem
- PyPI
- Packages
- dparse
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1333, CWE-400
- Reviewed
- 2022-09-27
Affected packages
• PyPI dparse: < 0.5.2 → fixed in 0.5.2
Description
Impact
dparse versions prior to 0.5.1 contain a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service).
All users parsing index server URLs with dparse are impacted by this vulnerability.
Patches
The Patch is applied in the `0.5.2` version, all users are recommended to upgrade as soon as possible.
Workarounds
Avoid passing index server URLs in the source file to be parsed.
References
https://github.com/pyupio/dparse/tree/security/remove-intensive-regex
For more information
If you have any questions or comments about this advisory:
• Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2022-39280 dparse is a parser for Python dependency files. vulnerability
References
- https://github.com/pyupio/dparse/security/advisories/GHSA-8fg9-p83m-x5pq web
- https://nvd.nist.gov/vuln/detail/CVE-2022-39280 advisory
- https://github.com/pyupio/dparse/commit/8c990170bbd6c0cf212f1151e9025486556062d5 web
- https://github.com/pyupio/dparse/commit/d87364f9db9ab916451b1b036cfeb039e726e614 web
- https://github.com/pypa/advisory-database/tree/main/vulns/dparse/PYSEC-2022-301.yaml web
- https://github.com/pyupio/dparse package
- https://owasp.org/www-community/attacks/Regular_expression_Denial_of_Service_-_ReDoS web