GitHub Advisoryadvisory · RubyGems

GHSA-8fqx-7pv4-3jwm Improper Input Validation in actionpack

MEDIUM Published 2017-10-24 Modified 2023-05-26 Official page ↗
Aliases
CVE-2008-7248
Ecosystem
RubyGems
Packages
actionpack
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 2.1.0, < 2.1.3 → fixed in 2.1.3 • RubyGems actionpack: >= 2.2.0, < 2.2.2 → fixed in 2.2.2

Description

Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote attackers to bypass cross-site request forgery (CSRF) protection for requests to applications that rely on this protection, as demonstrated using text/plain.

Related

Alias · CVE (1)

  • CVE-2008-7248 Ruby on Rails 2.1 before 2.1.3 and 2.2.x before 2.2.2 does not verify tokens for requests with certain content types, which allows remote… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References