GitHub Advisoryadvisory · Packagist

GHSA-8g35-7rmw-7f59 Shopware Vulnerable to Blind SQL-injection in DAL aggregations

HIGH Published 2025-04-08 Modified 2025-05-12 Official page ↗
Aliases
CVE-2025-27892
Ecosystem
Packagist
Packages
shopware/core, shopware/platform
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-89
Reviewed
2025-04-08

Affected packages

• Packagist shopware/core: >= 6.7.0.0-rc1, < 6.7.0.0-rc2 → fixed in 6.7.0.0-rc2 • Packagist shopware/platform: >= 6.7.0.0-rc1, < 6.7.0.0-rc2 → fixed in 6.7.0.0-rc2 • Packagist shopware/core: >= 6.6.0.0, < 6.6.10.3 → fixed in 6.6.10.3 • Packagist shopware/platform: >= 6.6.0.0, < 6.6.10.3 → fixed in 6.6.10.3 • Packagist shopware/core: < 6.5.8.18 → fixed in 6.5.8.18 • Packagist shopware/platform: < 6.5.8.18 → fixed in 6.5.8.18

Description

Impact The Shopware application API contains a search functionality which enables users to search through information stored within their Shopware instance. The searches performed by this function can be aggregated using the parameters in the “aggregations” object. The ‘name’ field in this “aggregations” in nested object is vulnerable SQL-injection and can be exploited using SQL parameters. Patches Update to Shopware 6.6.10.3 Workarounds For older versions of 6.5 or 6.4 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Credit Redteam Pentesting

Related

Alias · CVE (1)

  • CVE-2025-27892 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the /api/search/order endpoint. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References