GitHub Advisoryadvisory · Maven
GHSA-8h77-3xwr-hqhh Cross-site scripting in Jenkins Kiuwan Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2021-21666
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:kiuwanJenkinsPlugin
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-06-14
Affected packages
• Maven org.jenkins-ci.plugins:kiuwanJenkinsPlugin: < 1.6.1 → fixed in 1.6.1
Description
Jenkins Kiuwan Plugin 1.6.0 and earlier does not escape query parameters in an error message for a form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.
Only older releases of Jenkins are affected by this vulnerability. Jenkins 2.275 and newer, LTS 2.263.2 and newer include a protection preventing this from being exploitable.
Jenkins Kiuwan Plugin 1.6.1 escapes affected parts of the error message in the form validation endpoint.
Related
Alias · CVE (1)
- CVE-2021-21666 Jenkins Kiuwan Plugin 1.6.0 and earlier does not escape query parameters in an error message for a form validation endpoint, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-21666 advisory
- https://github.com/jenkinsci/kiuwan-plugin/commit/a5f6fdb1b8ad09d170547a4cc2b90c4829ef1f0a web
- https://github.com/jenkinsci/kiuwan-plugin package
- https://www.jenkins.io/security/advisory/2021-06-10/#SECURITY-2367 web
- http://www.openwall.com/lists/oss-security/2021/06/10/14 web