GitHub Advisoryadvisory · npm
GHSA-8h8q-6873-q5fj Next.js Vulnerable to Denial of Service with Server Components
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- next
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-770
- Reviewed
- 2026-05-11
Affected packages
• npm next: >= 13.0.0, < 15.5.16 → fixed in 15.5.16
• npm next: >= 16.0.0, < 16.2.5 → fixed in 16.2.5
Description
A vulnerability affects certain React Server Components packages for versions 19.x and frameworks that use the affected packages, including Next.js 13.x, 14.x, 15.x, and 16.x using the App Router. The issue is tracked upstream as CVE-2026-23870.
A specially crafted HTTP request can be sent to any App Router Server Function endpoint that, when deserialized, may trigger excessive CPU usage. This can result in denial of service in unpatched environments.
Related
Weakness · CWE (1)
- CWE-770 Allocation of Resources Without Limits or Throttling weakness
References
- https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh web
- https://github.com/vercel/next.js/security/advisories/GHSA-8h8q-6873-q5fj web
- https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-w94c-4vhp-22gx web
- https://nvd.nist.gov/vuln/detail/CVE-2026-23870 advisory
- https://github.com/vercel/next.js package