GitHub Advisoryadvisory · RubyGems

GHSA-8hc4-xxm3-5ppp Active Record subject to Regular Expression Denial-of-Service (ReDoS)

HIGH Published 2021-03-02 Modified 2023-07-03 Official page ↗
Aliases
CVE-2021-22880
Ecosystem
RubyGems
Packages
activerecord
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2021-03-02

Affected packages

• RubyGems activerecord: >= 5.0.0, < 5.2.4.5 → fixed in 5.2.4.5 • RubyGems activerecord: >= 6.0.0, < 6.0.3.5 → fixed in 6.0.3.5 • RubyGems activerecord: >= 6.1.0, < 6.1.2.1 → fixed in 6.1.2.1

Description

The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS) vulnerability. Carefully crafted input can cause the input validation in the `money` type of the PostgreSQL adapter in Active Record to spend too much time in a regular expression, resulting in the potential for a DoS attack. This only impacts Rails applications that are using PostgreSQL along with money type columns that take user input.

Related

Alias · CVE (1)

  • CVE-2021-22880 The PostgreSQL adapter in Active Record before 6.1.2.1, 6.0.3.5, 5.2.4.5 suffers from a regular expression denial of service (REDoS)… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References