GitHub Advisoryadvisory · Packagist

GHSA-8hcf-2m4v-f2rq SQL Injection in liftkit/database

CRITICAL Published 2023-01-16 Modified 2023-01-24 Official page ↗
Aliases
CVE-2016-15020
Ecosystem
Packagist
Packages
liftkit/database
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2023-01-24

Affected packages

• Packagist liftkit/database: < 2.13.2 → fixed in 2.13.2

Description

A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The name of the patch is 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.

Related

Alias · CVE (1)

  • CVE-2016-15020 A vulnerability was found in liftkit database up to 2.13.1. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References