GitHub Advisoryadvisory · PyPI

GHSA-8jf4-fcjr-68c2 Upsonic is vulnerable to Path Traversal attack through its os.path.join function

LOW Published 2025-06-19 Modified 2025-07-09 Official page ↗
Aliases
CVE-2025-6278
Ecosystem
PyPI
Packages
upsonic
Severity
Low
CVSS vector
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-22
Reviewed
2025-07-09

Affected packages

• PyPI upsonic: < 0.56.0 → fixed in 0.56.0

Description

A vulnerability classified as critical was found in Upsonic up to 0.55.6. This vulnerability affects the function os.path.join of the file markdown/server.py. The manipulation of the argument file.filename leads to path traversal. The exploit has been disclosed to the public and may be used.

Related

Alias · CVE (1)

  • CVE-2025-6278 A vulnerability classified as critical was found in Upsonic up to 0.55.6. vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References