GitHub Advisoryadvisory · npm
GHSA-8jh9-wqpf-q52c sweetalert2 v8.19.1 and above contains hidden functionality
LOW
Official page ↗
- Ecosystem
- npm
- Packages
- sweetalert2
- Severity
- Low
- Weaknesses
- CWE-912
- Reviewed
- 2022-11-23
Affected packages
• npm sweetalert2: >= 8.19.1, < 11.22.4 → fixed in 11.22.4
Description
`sweetalert2` versions 8.19.1 and up until 9.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions below 8.19.1.
Workaround
Users who are unable to update to the fixed version (11.22.4) can use package versions 8.19.0 and below, as they do not contain the hidden functionality.
Related
Weakness · CWE (1)
- CWE-912 Hidden Functionality weakness