GitHub Advisoryadvisory · Packagist

GHSA-8jj2-x2gc-ggm7 Drupal Core Cross-site scripting vulnerability

MEDIUM Published 2022-05-24 Modified 2024-04-23 Official page ↗
Aliases
CVE-2020-13666
Ecosystem
Packagist
Packages
drupal/core, drupal/drupal
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-23

Affected packages

• Packagist drupal/core: >= 8.8.0, < 8.8.10 → fixed in 8.8.10 • Packagist drupal/core: >= 8.9.0, < 8.9.6 → fixed in 8.9.6 • Packagist drupal/core: >= 9.0.0, < 9.0.6 → fixed in 9.0.6 • Packagist drupal/core: >= 7.0.0, < 7.73 → fixed in 7.73 • Packagist drupal/drupal: >= 7.0.0, < 7.73 → fixed in 7.73 • Packagist drupal/drupal: >= 8.8.0, < 8.8.10 → fixed in 8.8.10 • Packagist drupal/drupal: >= 8.9.0, < 8.9.6 → fixed in 8.9.6 • Packagist drupal/drupal: >= 9.0.0, < 9.0.6 → fixed in 9.0.6

Description

Cross-site scripting vulnerability in Drupal Core. Drupal AJAX API does not disable JSONP by default, allowing for an XSS attack. This issue affects: Drupal Drupal Core 7.x versions prior to 7.73; 8.8.x versions prior to 8.8.10; 8.9.x versions prior to 8.9.6; 9.0.x versions prior to 9.0.6.

Related

Alias · CVE (1)

  • CVE-2020-13666 Cross-site scripting vulnerability in Drupal Core. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References