GitHub Advisoryadvisory · PyPI

GHSA-8jj7-5vxc-pg2q Integer overflow in TensorFlow

HIGH Published 2022-02-09 Modified 2024-11-07 Official page ↗
Aliases
CVE-2022-23587
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-190
Reviewed
2022-02-04

Affected packages

• PyPI tensorflow: < 2.5.3 → fixed in 2.5.3 • PyPI tensorflow: >= 2.6.0, < 2.6.3 → fixed in 2.6.3 • PyPI tensorflow: >= 2.7.0, < 2.7.1 → fixed in 2.7.1 • PyPI tensorflow-cpu: < 2.5.3 → fixed in 2.5.3 • PyPI tensorflow-cpu: >= 2.6.0, < 2.6.3 → fixed in 2.6.3 • PyPI tensorflow-cpu: >= 2.7.0, < 2.7.1 → fixed in 2.7.1 • PyPI tensorflow-gpu: < 2.5.3 → fixed in 2.5.3 • PyPI tensorflow-gpu: >= 2.6.0, < 2.6.3 → fixed in 2.6.3 • PyPI tensorflow-gpu: >= 2.7.0, < 2.7.1 → fixed in 2.7.1

Description

Impact Under certain scenarios, Grappler component of TensorFlow is vulnerable to an integer overflow during cost estimation for crop and resize. Since the cropping parameters are user controlled, a malicious person can trigger undefined behavior. Patches We have patched the issue in GitHub commit 0aaaae6eca5a7175a193696383f582f53adab23f. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Related

Alias · CVE (1)

  • CVE-2022-23587 Tensorflow is an Open Source Machine Learning Framework. vulnerability

Weakness · CWE (1)

  • CWE-190 Integer Overflow or Wraparound weakness

References