GitHub Advisoryadvisory · Packagist
GHSA-8jxc-5f94-22vh Magento Open Source allows Server-Side Request Forgery (SSRF)
MEDIUM
Official page ↗
- Aliases
- CVE-2023-26366
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2025-03-04
Affected packages
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-beta2 → fixed in 2.4.7-beta2
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p3 → fixed in 2.4.6-p3
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p5 → fixed in 2.4.5-p5
• Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p6 → fixed in 2.4.4-p6
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to arbitrary file system read. A high-privileged authenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction, scope is changed due to the fact that an attacker can enforce file read outside the application's path boundary.
Related
Alias · CVE (1)
- CVE-2023-26366 Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness