GitHub Advisoryadvisory · RubyGems
GHSA-8jxj-9r5f-w3m2 Puppet allows local users to obtain sensitive configuration information
LOW
Official page ↗
- Aliases
- CVE-2012-3866
- Ecosystem
- RubyGems
- Packages
- puppet
- Severity
- Low
- Reviewed
- 2020-06-16
Affected packages
• RubyGems puppet: >= 2.7.0, < 2.7.18 → fixed in 2.7.18
Description
`lib/puppet/defaults.rb` in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for `last_run_report.yaml`, which allows local users to obtain sensitive configuration information by leveraging access to the puppet master server to read this file.
Related
Alias · CVE (1)
- CVE-2012-3866 lib/puppet/defaults.rb in Puppet 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, uses 0644 permissions for last_run_report.yaml,… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-3866 advisory
- https://github.com/puppetlabs/puppet/commit/fd44bf5e6d0d360f6a493d663b653c121fa83c3f web
- https://bugzilla.redhat.com/show_bug.cgi?id=839135 web
- https://github.com/puppetlabs/puppet package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-3866.yml web
- https://www.puppet.com/security/cve/cve-2012-3866-lastrunreportyaml-world-readable web
- http://lists.opensuse.org/opensuse-updates/2012-07/msg00036.html web
- http://puppetlabs.com/security/cve/cve-2012-3866 web
- http://www.debian.org/security/2012/dsa-2511 web
- http://www.ubuntu.com/usn/USN-1506-1 web