GitHub Advisoryadvisory · PyPI
GHSA-8m57-j273-2qg9 OpenEXR invalid read
MEDIUM
Official page ↗
- Aliases
- CVE-2017-9112
- Ecosystem
- PyPI
- Packages
- OpenEXR
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- Reviewed
- 2025-04-22
Affected packages
• PyPI OpenEXR: < 2.2.1 → fixed in 2.2.1
Description
In OpenEXR 2.2.0, an invalid read of size 1 in the getBits function in ImfHuf.cpp could cause the application to crash.
Related
Alias · CVE (1)
- CVE-2017-9112 In OpenEXR 2.2.0, an invalid read of size 1 in the getBits function in ImfHuf.cpp could cause the application to crash. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-9112 advisory
- https://github.com/openexr/openexr/issues/232 web
- https://github.com/openexr/openexr/pull/233 web
- https://github.com/AcademySoftwareFoundation/openexr package
- https://github.com/openexr/openexr/releases/tag/v2.2.1 web
- https://lists.debian.org/debian-lts-announce/2020/08/msg00056.html web
- https://usn.ubuntu.com/4148-1 web
- http://www.openwall.com/lists/oss-security/2017/05/12/5 web