GitHub Advisoryadvisory · Packagist
GHSA-8m97-xc46-rw9w phpMyAdmin Unsafe comparison of XSRF/CSRF token
HIGH
Official page ↗
- Aliases
- CVE-2016-2041
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-203
- Reviewed
- 2024-04-24
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.0, < 4.0.10.13 → fixed in 4.0.10.13
• Packagist phpmyadmin/phpmyadmin: >= 4.4, < 4.4.15.3 → fixed in 4.4.15.3
• Packagist phpmyadmin/phpmyadmin: >= 4.5, < 4.5.4 → fixed in 4.5.4
Description
libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time algorithm for comparing CSRF tokens, which makes it easier for remote attackers to bypass intended access restrictions by measuring time differences.
Related
Alias · CVE (1)
- CVE-2016-2041 libraries/common.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not use a constant-time… vulnerability
Weakness · CWE (1)
- CWE-203 Observable Discrepancy weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-2041 advisory
- https://github.com/phpmyadmin/phpmyadmin/commit/ec0e88e37ef30a66eada1c072953f4ec385a3e49 web
- https://github.com/phpmyadmin/composer package
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176483.html web
- http://lists.fedoraproject.org/pipermail/package-announce/2016-February/176739.html web
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00028.html web
- http://lists.opensuse.org/opensuse-updates/2016-02/msg00049.html web
- http://www.debian.org/security/2016/dsa-3627 web
- http://www.phpmyadmin.net/home_page/security/PMASA-2016-5.php web