GitHub Advisoryadvisory · Packagist
GHSA-8mq8-c243-2335 Magento Cross-site Scripting vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-49557
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-08-15
Affected packages
• Packagist magento/community-edition: < 2.4.4-p15 → fixed in 2.4.4-p15
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p14 → fixed in 2.4.5-p14
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p12 → fixed in 2.4.6-p12
• Packagist magento/community-edition: >= 2.4.7-p1, < 2.4.7-p7 → fixed in 2.4.7-p7
• Packagist magento/community-edition: 2.4.8 (no fix yet)
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be exploited by a low-privileged attacker to inject malicious scripts into vulnerable form fields. These scripts may be used to escalate privileges within the application or compromise sensitive user data. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field. Scope is changed.
Related
Alias · CVE (1)
- CVE-2025-49557 Adobe Commerce versions 2.4.9-alpha1, 2.4.8-p1, 2.4.7-p6, 2.4.6-p11, 2.4.5-p13, 2.4.4-p14 and earlier are affected by a stored Cross-Site… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness