GitHub Advisoryadvisory · Maven

GHSA-8mr5-h28g-36qx Spring AOP functionality (Struts) vulnerable to DoS attack

HIGH Published 2018-10-16 Modified 2022-04-26 Official page ↗
Aliases
CVE-2017-9787
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Reviewed
2020-06-16

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.3.7, < 2.3.33 → fixed in 2.3.33 • Maven org.apache.struts:struts2-core: >= 2.5.0, < 2.5.12 → fixed in 2.5.12

Description

When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.

Related

Alias · CVE (1)

  • CVE-2017-9787 When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. vulnerability

References