GitHub Advisoryadvisory · Packagist
GHSA-8mwx-wpp4-5xh4 Magento Broken authentication and session managememt
CRITICAL
Official page ↗
- Aliases
- CVE-2019-8149
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287
- Reviewed
- 2024-05-15
Affected packages
• Packagist magento/community-edition: >= 2.2, < 2.2.10 → fixed in 2.2.10
• Packagist magento/community-edition: >= 2.3, < 2.3.2-p1 → fixed in 2.3.2-p1
Description
Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An unauthenticated user can append arbitrary session id that will not be invalidated by subsequent authentication.
Related
Alias · CVE (1)
- CVE-2019-8149 Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness