GitHub Advisoryadvisory · PyPI

GHSA-8p42-7597-p2f6 dcnnt-py is vulnerable to command injection via Notification Handler

MEDIUM Published 2024-04-27 Modified 2024-04-30 Official page ↗
Aliases
CVE-2023-1000
Ecosystem
PyPI
Packages
dcnnt
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-77
Reviewed
2024-04-30

Affected packages

• PyPI dcnnt: < 0.9.1 → fixed in 0.9.1

Description

A vulnerability was found in cyanomiko dcnnt-py up to 0.9.0. It has been classified as critical. Affected is the function main of the file dcnnt/plugins/notifications.py of the component Notification Handler. The manipulation leads to command injection. It is possible to launch the attack remotely. Upgrading to version 0.9.1 is able to address this issue. The patch is identified as b4021d784a97e25151a5353aa763a741e9a148f5. It is recommended to upgrade the affected component. VDB-262230 is the identifier assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2023-1000 A vulnerability was found in cyanomiko dcnnt-py up to 0.9.0. vulnerability

Weakness · CWE (1)

  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References