GitHub Advisoryadvisory · Maven

GHSA-8p4m-62gp-33j4 Users with Overall/Read access can enumerate credential IDs in Pipeline GitHub Notify Step Plugin

MEDIUM Published 2022-05-24 Modified 2023-01-14 Official page ↗
Aliases
CVE-2020-2118
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:pipeline-build-step
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-285
Reviewed
2023-01-14

Affected packages

• Maven org.jenkins-ci.plugins:pipeline-build-step: < 1.0.5 → fixed in 1.0.5

Description

Pipeline GitHub Notify Step Plugin 1.0.4 and earlier provides a list of applicable credential IDs to allow users configuring the plugin to select the one to use. This functionality does not correctly check permissions, allowing any user with Overall/Read permission to get a list of valid credentials IDs. Those can be used as part of an attack to capture the credentials using another vulnerability. An enumeration of credentials IDs in Pipeline GitHub Notify Step Plugin 1.0.5 requires the permission to configure a project.

Related

Alias · CVE (1)

  • CVE-2020-2118 A missing permission check in Jenkins Pipeline GitHub Notify Step Plugin 1.0.4 and earlier in form-related methods allowed users with… vulnerability

Weakness · CWE (1)

  • CWE-285 Improper Authorization weakness

References