GitHub Advisoryadvisory · Go
GHSA-8pff-p3gx-w4jf Mattermost Server vulnerable to XSS via an uploaded file
MEDIUM
Official page ↗
- Aliases
- CVE-2017-18904
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2026-01-12
Affected packages
• Go github.com/mattermost/mattermost-server: < 3.9.2 → fixed in 3.9.2
• Go github.com/mattermost/mattermost-server: >= 3.10.0, < 3.10.2 → fixed in 3.10.2
Description
An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. It allows XSS via an uploaded file.
Related
Alias · CVE (1)
- CVE-2017-18904 An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-18904 advisory
- https://github.com/mattermost/mattermost/commit/6a2754376c8c8270be5e11e3fdab589659d0cc8d web
- https://github.com/mattermost/mattermost/commit/bde06a7bc3a03a56da224c1ffcd8bffb0af8071b web
- https://github.com/mattermost/mattermost/commit/f06c5bef4d78966c60b153bbec6eea4ec0be9e68 web
- https://github.com/mattermost/mattermost package
- https://mattermost.com/security-updates web