GitHub Advisoryadvisory · PyPI
GHSA-8q8v-28rm-qw4w Borg Improper Access Control vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2017-15914
- Ecosystem
- PyPI
- Packages
- borgbackup
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
- Reviewed
- 2024-04-29
Affected packages
• PyPI borgbackup: >= 1.1.0b1, < 1.1.3 → fixed in 1.1.3
Description
Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.
Related
Alias · CVE (1)
- CVE-2017-15914 Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3. vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-15914 advisory
- https://github.com/borgbackup/borg/commit/75854c1243b29ec5558be6fdefe365cd438abb4c web
- https://github.com/borgbackup/borg package
- https://github.com/pypa/advisory-database/tree/main/vulns/borgbackup/PYSEC-2018-105.yaml web
- http://borgbackup.readthedocs.io/en/stable/changes.html#version-1-1-3-2017-11-27 web