GitHub Advisoryadvisory · RubyGems

GHSA-8qhq-rq4j-8prj Elasticsearch Logstash allows remote attackers to execute arbitrary commands

HIGH Published 2022-05-14 Modified 2025-04-16 Official page ↗
Aliases
CVE-2014-4326
Ecosystem
RubyGems
Packages
logstash
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-78
Reviewed
2025-04-14

Affected packages

• RubyGems logstash: >= 1.0.14, < 1.4.2 → fixed in 1.4.2

Description

Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) `zabbix.rb` or (2) `nagios_nsca.rb` in `outputs/`.

Related

Alias · CVE (1)

  • CVE-2014-4326 Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1)… vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References