GitHub Advisoryadvisory · RubyGems, Maven

GHSA-8qxg-mff5-j3wc RubyGems Path Traversal vulnerability

MEDIUM Published 2022-05-14 Modified 2023-03-10 Official page ↗
Aliases
CVE-2018-1000079
Ecosystem
RubyGems, Maven
Packages
rubygems-update, org.jruby:jruby-stdlib
Severity
Moderate
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Weaknesses
CWE-22
Reviewed
2023-03-10

Affected packages

• RubyGems rubygems-update: < 2.7.6 → fixed in 2.7.6 • Maven org.jruby:jruby-stdlib: < 9.1.16.0 → fixed in 9.1.16.0

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem writing to arbitrary filesystem locations during installation. This attack appears to be exploitable via installation of a malicious gem. This vulnerability is fixed in 2.7.6.

Related

Alias · CVE (1)

  • CVE-2018-1000079 RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5… vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References