GitHub Advisoryadvisory · Packagist
GHSA-8r2q-865v-wm8j Drupal SpamSpan Cross-Site Scripting (XSS) vulnerability
LOW
Official page ↗
- Aliases
- CVE-2025-31687
- Ecosystem
- Packagist
- Packages
- drupal/spamspan
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-04-02
Affected packages
• Packagist drupal/spamspan: < 3.2.1 → fixed in 3.2.1
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS). This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.
Related
Alias · CVE (1)
- CVE-2025-31687 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness