GitHub Advisoryadvisory · Packagist

GHSA-8r6h-m72v-38fg Shopware vulnerable to Improper Input Validation of Clearance sale in cart

MEDIUM Published 2023-01-17 Modified 2023-01-25 Official page ↗
Aliases
CVE-2023-22730
Ecosystem
Packagist
Packages
shopware/platform, shopware/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-20
Reviewed
2023-01-17

Affected packages

• Packagist shopware/platform: < 6.4.18.1 → fixed in 6.4.18.1 • Packagist shopware/core: < 6.4.18.1 → fixed in 6.4.18.1

Description

Impact It is possible to put the same line item multiple one in the cart using API, the Cart Validators checked the line item's individuality and the user was able to skip the clearance sale in cart Patches The problem has been fixed with 6.4.18.1 Workarounds For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Or disable the newsletter registration completely. References https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates

Related

Alias · CVE (1)

  • CVE-2023-22730 Shopware is an open source commerce platform based on Symfony Framework and Vue js. vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References