GitHub Advisoryadvisory · Packagist

GHSA-8r7x-qq55-74v2 Moodle does not enforce the forceloginforprofiles setting

MEDIUM Published 2022-05-13 Modified 2024-01-19 Official page ↗
Aliases
CVE-2013-1830
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-284
Reviewed
2024-01-19

Affected packages

• Packagist moodle/moodle: <= 2.1.10 (no fix yet) • Packagist moodle/moodle: >= 2.2.0, < 2.2.8 → fixed in 2.2.8 • Packagist moodle/moodle: >= 2.3.0, < 2.3.5 → fixed in 2.3.5 • Packagist moodle/moodle: >= 2.4.0, < 2.4.2 → fixed in 2.4.2

Description

`user/view.php` in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the `forceloginforprofiles` setting, which allows remote attackers to obtain sensitive course-profile information by leveraging the guest role, as demonstrated by a Google search.

Related

Alias · CVE (1)

  • CVE-2013-1830 user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References